Mise en place du protocole Hot Standby Router Protocol (HSRP) sur routeur Cisco

De Wiki de Romain RUDIGER
Aller à : navigation, rechercher

Mise en place du protocole Hot Standby Router Protocol (HSRP) sur routeur Cisco.

Participant : Romain RÜDIGER.

Période : 05/09.

Introduction

HSRP est un protocole de Cisco qui permet de mettre en place une redondance des routeurs en utilisant une adresse virtuelle et la notion d'équipement actif et en attente. Pour plus d'information voir l'article de Wikipedia : [1].

Dans ce document vous retrouverez un exemple de configuration.

Mise en place

Prenons deux routeurs :

  • RA
    IP = 10.1.1.30
  • RB
    IP = 10.1.1.29

Nous allons créer une adresse virtuelle qui sera prise par l'un des deux routeurs, avec en priorité le routeur RB. Vous retrouverez ci-dessous la configuration des deux routeurs.

Dont voici la configuration de base pour RA (cisco 2600) :

interface FastEthernet0
 description trunk to SW1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 speed 100
 full-duplex
!
interface FastEthernet0.1
 description VLAN1
 encapsulation dot1Q 1
 ip address 10.1.1.30 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 standby 102 ip 10.1.1.31
 standby 102 priority 140
 standby 102 preempt
 standby 102 track Ethernet0

pour RB (cisco 1700) :

interface FastEthernet0/1
 description trunk to SW1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 speed 100
 full-duplex
!
interface FastEthernet0/1.1
 description VLAN1
 encapsulation dot1Q 1
 ip address 10.1.1.29 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 standby 102 ip 10.1.1.31
 standby 102 priority 150
 standby 102 preempt
 standby 102 track FastEthernet0/0

Conclusion

HSRP permet de mettre rapidement en place une continuité de service.